一人もくもく会 α verでサービス開始しました。
請求書作成システム α verでサービス開始しました。

WordPress3.0をmysql4.0で使う

現在のWordPressの最新版である3.0をインストールしようとしたところ、
なんとmysqlのバージョンが4.0だったためインストールが出来なかった。

しかし無理やりインストールしてみたのでそれの備忘録。
とりあえず投稿などはできるようですが、正しく動くかどうかは一切保証できません。

wp-admin/install.php
150行目に$mysql_compatでバージョンをチェックしているので、次の行に

$mysql_compat = true;

として無理やりOKにする。

wp-includes/wp-db.php
同じ意味で1511行目check_database_versionの一番最初の行に

return;

をいれる。

上記でデータベースバージョンのチェックを無視。
あとはSQLをver4にあわせなければならない。
とりあえず下記を修正すればインストール、投稿あたりはいける。

wp-admin/includes/schema.php
25行目まで、$charset_collateに値を入れているため次の行に

$charset_collate = '';

文字コード設定をなくす。

あとはON DUPLICATEというクエリを使用しているところがあるので、これを修正する。

wp-includes/functions.php
604行目をまるまる下記に置き換え。

	if ($wpdb->get_row($wpdb->prepare("SELECT * FROM `$wpdb->options` WHERE `option_name` = %s", $option))) {
		$result = $wpdb->query( $wpdb->prepare( "UPDATE `$wpdb->options` SET `option_value` = %s, `autoload` = %s WHERE `option_name` = %s", $value, $autoload, $option ) );
	} else {
		$result = $wpdb->query( $wpdb->prepare( "INSERT INTO `$wpdb->options` (`option_name`, `option_value`, `autoload`) VALUES (%s, %s, %s)", $option, $value, $autoload ) );
	}

wp-includes/taxonomy.php
使っているのかは知らないが取りあえず1777からの2行を下記に置き換え。

		if ( $values ) {
			if ($wpdb->get_row($wpdb->prepare("SELECT * FROM $wpdb->term_relationships WHERE object_id = %d AND term_taxonomy_id = %d", $object_id, $tt_id))) {
				$wpdb->query("INSERT INTO $wpdb->term_relationships (object_id, term_taxonomy_id, term_order) VALUES " . join(',', $values) . " ");
			} else {
				$wpdb->query($wpdb->prepare("UPDATE $wpdb->term_relationships SET term_order = %d WHERE object_id = %d AND term_taxonomy_id = %d", $term_order, $object_id, $tt_id));
			}
		}

これでなんとなく動くようだ。